From dc55b8b2341483a8b5d14a4335a609cc92eaceb2 Mon Sep 17 00:00:00 2001
From: David Thompson <dthompson2@worcester.edu>
Date: Thu, 26 Jun 2014 18:07:29 -0400
Subject: [PATCH] gnu: Enable libvpx support in ffmpeg.

* gnu/packages/video.scm (ffmpeg): Add libvpx input.
---
 gnu/packages/video.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 8b63c594739..4509d815289 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -69,6 +69,7 @@ (define-public ffmpeg
        ("opus" ,opus)
        ("libtheora" ,libtheora)
        ("libvorbis" ,libvorbis)
+       ("libvpx" ,libvpx)
        ("patchelf" ,patchelf)
        ("speex" ,speex)
        ("zlib", zlib)))
@@ -142,7 +143,6 @@ (define-public ffmpeg
 ;;   --enable-libvidstab      enable video stabilization using vid.stab [no]
 ;;   --enable-libvo-aacenc    enable AAC encoding via libvo-aacenc [no]
 ;;   --enable-libvo-amrwbenc  enable AMR-WB encoding via libvo-amrwbenc [no]
-;;   --enable-libvpx          enable VP8 and VP9 de/encoding via libvpx [no]
 ;;   --enable-libwavpack      enable wavpack encoding via libwavpack [no]
 ;;   --enable-libx264         enable H.264 encoding via x264 [no]
 ;;   --enable-libxavs         enable AVS encoding via xavs [no]
@@ -165,6 +165,7 @@ (define-public ffmpeg
                       "--enable-libspeex"
                       "--enable-libtheora"
                       "--enable-libvorbis"
+                      "--enable-libvpx"
                       ;; drop special machine instructions not supported
                       ;; on all instances of the target
                       ,@(if (string-prefix? "x86_64"
-- 
GitLab