From dc91c10f2bc21982f26a9f90721f23b79b5668b7 Mon Sep 17 00:00:00 2001
From: Manolis Ragkousis <manolis837@gmail.com>
Date: Sat, 1 Mar 2014 14:48:09 +0000
Subject: [PATCH] gnu: hurd: Add Hurd headers.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

* gnu/packages/hurd.scm (hurd-headers): New variable.

Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
---
 gnu/packages/hurd.scm | 44 ++++++++++++++++++++++++++++++++++++++++++-
 1 file changed, 43 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index 3edccbdd1cd..f1e7dbc9dc7 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -22,7 +22,9 @@ (define-module (gnu packages hurd)
   #:use-module (guix packages)
   #:use-module (guix build-system gnu)
   #:use-module (gnu packages flex)
-  #:use-module (gnu packages bison))
+  #:use-module (gnu packages bison)
+  #:use-module (gnu packages perl)
+  #:use-module (gnu packages autotools))
 
 (define-public gnumach-headers
   (package
@@ -86,3 +88,43 @@ (define-public mig
 for other software in the GNU system that uses Mach-based inter-process
 communication.")
     (license gpl2+)))
+
+(define-public hurd-headers
+  (package
+    (name "hurd-headers")
+    (version "0.5")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://gnu/hurd/hurd-"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "0lvkz3r0ngb4bsn2hzdc9vjpyrfa3ls36jivrvy1n7f7f55zan7q"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(;; Autoconf shouldn't be necessary but there seems to be a bug in the
+       ;; build system triggering its use.
+       ("autoconf" ,autoconf)
+
+       ("mig" ,mig)))
+    (arguments
+     `(#:phases (alist-replace
+                 'install
+                 (lambda _
+                   (zero? (system* "make" "install-headers" "no_deps=t")))
+                 (alist-delete 'build %standard-phases))
+
+       #:configure-flags '(;; Pretend we're on GNU/Hurd; 'configure' wants
+                           ;; that.
+                           "--host=i686-pc-gnu"
+
+                           ;; Reduce set of dependencies.
+                           "--without-parted")
+
+       #:tests? #f))
+    (home-page "http://www.gnu.org/software/hurd/hurd.html")
+    (synopsis "GNU Hurd headers")
+    (description
+     "This package provides C headers of the GNU Hurd, used to build the GNU C
+Library and other user programs.")
+    (license gpl2+)))
-- 
GitLab