From de73dbf62d2696746f6de9dce79b1fe537c51613 Mon Sep 17 00:00:00 2001
From: Eric Dvorsak <eric@dvorsak.fr>
Date: Sat, 25 Jul 2015 21:36:51 +0200
Subject: [PATCH] gnu: Add python-httplib2.

* gnu/packages/python.scm (python-httplib2, python-httplib2): New variables.

Signed-off-by: Alex Kost <alezost@gmail.com>
---
 gnu/packages/python.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 817b6cdd1b6..ab89fd0d60f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -298,6 +298,34 @@ (define-public python-psutil
 (define-public python2-psutil
   (package-with-python2 python-psutil))
 
+(define-public python-httplib2
+  (package
+    (name "python-httplib2")
+    (version "0.9.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://pypi.python.org/packages/source/h/httplib2/httplib2-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "1xc3clbrf77r0600kja71j7hk1218sjiq0gfmb8vjdajka8kjqxw"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-setuptools" ,python-setuptools)))
+    (home-page
+     "https://github.com/jcgregorio/httplib2")
+    (synopsis "Comprehensive HTTP client library")
+    (description
+     "A comprehensive HTTP client library supporting many features left out of
+other HTTP libraries.")
+    (license license:expat)))
+
+(define-public python2-httplib2
+  (package-with-python2 python-httplib2))
+
 (define-public python-ecdsa
   (package
     (name "python-ecdsa")
-- 
GitLab