diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 766aea4bfdc3ad72fa35c087526777315eddbe28..14af246e997bd37fb16824ce5cdf69d529591943 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -158,6 +158,8 @@ (define gcc-boot0
                    (srfi srfi-1)
                    (srfi srfi-26))
         ,@(substitute-keyword-arguments (package-arguments gcc-4.8)
+            ((#:validate-runpath? _)
+             #t)
             ((#:configure-flags flags)
              `(append (list ,(string-append "--target=" (boot-triplet))
 
@@ -500,11 +502,6 @@ (define-public gcc-final
 
        #:allowed-references ("out" "lib" ,glibc-final)
 
-       ;; Things like libasan.so and libstdc++.so NEED ld.so and/or
-       ;; libgcc_s.so but RUNPATH is empty.  This is a false positive, so turn
-       ;; it off.
-       #:validate-runpath? #f
-
        ;; Build again GMP & co. within GCC's build process, because it's hard
        ;; to do outside (because GCC-BOOT0 is a cross-compiler, and thus
        ;; doesn't honor $LIBRARY_PATH, which breaks `gnu-build-system'.)
@@ -529,6 +526,11 @@ (define-public gcc-final
                                              "/lib")
                               flag))
                         ,flags)))
+           ((#:validate-runpath? _)
+            ;; Things like libasan.so and libstdc++.so NEED ld.so and/or
+            ;; libgcc_s.so but RUNPATH is empty.  This is a false positive, so
+            ;; turn it off.
+            #f)
            ((#:phases phases)
             `(alist-delete 'symlink-libgcc_eh ,phases)))))
 
diff --git a/gnu/packages/cross-base.scm b/gnu/packages/cross-base.scm
index 565a4a82209b7ea151a3a6e8384e31932b5dcc83..0f15a0aaec8ca3f0f2571527f85ae9649ff13f33 100644
--- a/gnu/packages/cross-base.scm
+++ b/gnu/packages/cross-base.scm
@@ -175,6 +175,8 @@ (define (cross? x)
                      #t)))
                ,phases)
              phases)))
+      ((#:validate-runpath? _)
+       #t)
       ((#:strip-binaries? _)
        ;; Disable stripping as this can break binaries, with object files of
        ;; libgcc.a showing up as having an unknown architecture.  See
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 68c9e98762f6effcdaf7e64f0790e81e2837f762..4c06f84155143e83ba9f3b4c1ede6255557dd362 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -189,6 +189,11 @@ (define-public gcc-4.7
                                    ,(if stripped? "-g0" "-g")))))
 
          #:tests? #f
+
+         ;; libstdc++.so NEEDs libgcc_s.so but somehow it doesn't get
+         ;; $(libdir) in its RUNPATH, so turn it off.
+         #:validate-runpath? #f
+
          #:phases
          (alist-cons-before
           'configure 'pre-configure