From dff624230a47a25d64ab5bd10378ca0e7053bd33 Mon Sep 17 00:00:00 2001
From: John Darrington <jmd@gnu.org>
Date: Fri, 27 Jun 2014 10:33:08 +0200
Subject: [PATCH] gnu: Add talkfilters.

* gnu/packages/games.scm (talkfilters): New variable.
---
 gnu/packages/games.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 22412e40938..8a2b2df0221 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -208,3 +208,23 @@ (define-public pingus
 level's exit.  The game is presented in a 2D side view.")
     ;; Some source files are under bsd-3 and gpl2+ licenses.
     (license gpl3+)))
+
+(define-public talkfilters
+  (package
+    (name "talkfilters")
+    (version "2.3.8")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "http://www.hyperrealm.com/" name "/"
+                           name  "-" version  ".tar.gz")) 
+       (sha256
+        (base32 "19nc5vq4bnkjvhk8srqddzhcs93jyvpm9r6lzjzwc1mgf08yg0a6"))))
+    (build-system gnu-build-system)
+    (home-page "http://www.gnu.org/software/talkfilters")
+    (synopsis "Convert English text to humorous dialects")
+    (description "The GNU Talk Filters are programs that convert English text
+into stereotyped or otherwise humorous dialects.  The filters are provided as
+a C library, so they can easily be integrated into other programs.")
+    (license gpl2+)))
+ 
-- 
GitLab