From e0884109847787f1e24258829a375dab9e40485b Mon Sep 17 00:00:00 2001
From: Mark H Weaver <mhw@netris.org>
Date: Tue, 7 Jul 2015 13:06:00 -0400
Subject: [PATCH] gnu: Add libmpeg2.

* gnu/packages/video.scm (libmpeg2): New variable.
---
 gnu/packages/video.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 259e858e7d4..456178565e1 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -161,6 +161,33 @@ (define-public liba52
 television and DVD.  It is also known as AC-3.")
     (license license:gpl2+)))
 
+(define-public libmpeg2
+  (package
+    (name "libmpeg2")
+    (version "0.5.1")
+    (source (origin
+              (method url-fetch)
+              ;; A mirror://sourceforge URI doesn't work, presumably
+              ;; because the SourceForge project is misconfigured.
+              (uri (string-append "http://libmpeg2.sourceforge.net/files/"
+                                  name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1m3i322n2fwgrvbs1yck7g5md1dbg22bhq5xdqmjpz5m7j4jxqny"))))
+    (inputs
+     `(("libx11" ,libx11)
+       ("libxext" ,libxext)
+       ("libxv" ,libxv)
+       ("libsm" ,libsm)
+       ("libice" ,libice)
+       ("sdl" ,sdl)))
+    (build-system gnu-build-system)
+    (home-page "http://libmpeg2.sourceforge.net/")
+    (synopsis "MPEG1 and MPEG2 video decoder library")
+    (description
+     "libmpeg2 is a library which can decode MPEG1 and MPEG2 video streams.")
+    (license license:gpl2+)))
+
 (define-public libass
   (package
     (name "libass")
-- 
GitLab