From e08ad76658f0bd1b9880c2388ae004ff0daca1cb Mon Sep 17 00:00:00 2001
From: Raoul Jean Pierre Bonnal <ilpuccio.febo@gmail.com>
Date: Sat, 11 Mar 2017 11:55:28 +1000
Subject: [PATCH] gnu: Add r-fnn.

* gnu/packages/statistics.scm (r-fnn): New variable.

Signed-off-by: Ben Woodcroft <donttrustben@gmail.com>
---
 gnu/packages/statistics.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 6ab64a5c8f8..ff2aab2a835 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -4421,3 +4421,24 @@ (define-public r-pbapply
 functions apply.  The implementation can easily be added to functions where
 showing the progress is useful e.g. bootstrap.")
     (license license:gpl2)))
+
+(define-public r-fnn
+  (package
+    (name "r-fnn")
+    (version "1.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "FNN" version))
+       (sha256
+        (base32
+         "1kncmiaraq1mrykb9fj3fsxswabk3l71fnp1vks0x9aay5xfk8mj"))))
+    (properties `((upstream-name . "FNN")))
+    (build-system r-build-system)
+    (home-page "http://cran.r-project.org/web/packages/FNN")
+    (synopsis "Fast nearest neighbor search algorithms and applications")
+    (description
+     "This package provides cover-tree and kd-tree fast k-nearest neighbor
+search algorithms and related applications including KNN classification,
+regression and information measures.")
+    (license license:gpl2+)))
-- 
GitLab