diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index efe58c542ee6ffad788355220a581cb84df035c1..35c782473c1fb19ce6e649af4e7b5add1e7f4616 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -238,6 +238,10 @@ (define-public camlp4
     (inputs `(("ocaml" ,ocaml)))
     (arguments
      '(#:tests? #f                                ;no documented test target
+       ;; a race-condition will lead byte and native targets to  mkdir _build
+       ;; which  fails on the second attempt.
+       #:parallel-build? #f
+       #:make-flags '("all")
        #:phases (modify-phases %standard-phases
                   (replace
                    'configure