From e0ddaa8be3fad4efbe3c8be8dfb8dc63a784f335 Mon Sep 17 00:00:00 2001
From: Julien Lepiller <julien@lepiller.eu>
Date: Sat, 31 Dec 2016 12:42:10 +0100
Subject: [PATCH] gnu: camlp4: Compile native version.

* gnu/packages/ocaml.scm (camlp4)[arguments]: Disable parallel-build.
  Change default target to "all" to compile native and byte version.

Signed-off-by: David Craven <david@craven.ch>
---
 gnu/packages/ocaml.scm | 4 ++++
 1 file changed, 4 insertions(+)

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index efe58c542ee..35c782473c1 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -238,6 +238,10 @@ (define-public camlp4
     (inputs `(("ocaml" ,ocaml)))
     (arguments
      '(#:tests? #f                                ;no documented test target
+       ;; a race-condition will lead byte and native targets to  mkdir _build
+       ;; which  fails on the second attempt.
+       #:parallel-build? #f
+       #:make-flags '("all")
        #:phases (modify-phases %standard-phases
                   (replace
                    'configure
-- 
GitLab