diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 207e501520d7d36b0afc955a03f601636bea8219..9bea0e68c1fa56a6d0b8833b7da749694281b0c7 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -115,7 +115,7 @@ (define-public keepassxc
     (source
      (origin
        (method url-fetch)
-       (uri (string-append "https://github.com/keepassxreboot/" name
+       (uri (string-append "https://github.com/keepassxreboot/keepassxc"
                            "/releases/download/" version "/keepassxc-"
                            version "-src.tar.xz"))
        (sha256