diff --git a/gnu/packages/weechat.scm b/gnu/packages/weechat.scm
index d88ad53166b2ae86b5203980a6e76e3a7542e248..18508dd09d3a8ff51d58d4eb0ce5f4d2f95cc410 100644
--- a/gnu/packages/weechat.scm
+++ b/gnu/packages/weechat.scm
@@ -47,11 +47,11 @@ (define-public weechat
     (name "weechat")
     (version "1.3")
     (source (origin
-             (method url-fetch)
-             (uri (string-append "http://weechat.org/files/src/weechat-"
+              (method url-fetch)
+              (uri (string-append "http://weechat.org/files/src/weechat-"
                                   version ".tar.gz"))
-             (sha256
-              (base32 "13b7dfs3sn71c51fi0bli5rzlsppil6gg1lzik3k8l43yhhqyv2w"))))
+              (sha256
+               (base32 "13b7dfs3sn71c51fi0bli5rzlsppil6gg1lzik3k8l43yhhqyv2w"))))
     (build-system gnu-build-system)
     (native-inputs `(("autoconf" ,autoconf)
                      ("pkg-config" ,pkg-config)
@@ -75,20 +75,14 @@ (define-public weechat
               ("python" ,python-2)
               ("perl" ,perl)
               ("tcl" ,tcl)))
-    (arguments `(#:configure-flags (list
-                                    (string-append
-                                     "--with-tclconfig="
-                                     (assoc-ref %build-inputs "tcl") "/lib"))
-                 #:phases (alist-cons-after
-                           'autogen 'fix-file
-                           (lambda _
-                             (substitute* "configure"
-                               (("/usr/bin/file") (which "file"))))
-                           (alist-cons-before
-                            'configure 'autogen
-                            (lambda _
-                              (zero? (system* "./autogen.sh")))
-                            %standard-phases))))
+    (arguments
+     `(#:configure-flags (list (string-append
+                                "--with-tclconfig="
+                                (assoc-ref %build-inputs "tcl") "/lib"))
+       #:phases (modify-phases %standard-phases
+                  (add-before 'configure 'autogen
+                    (lambda _
+                      (zero? (system* "./autogen.sh")))))))
     (synopsis "Extensible chat client")
     (description "WeeChat (Wee Enhanced Environment for Chat) is an
 Internet Relay Chat client, which is designed to be light and fast.