From e431eb670dd3d367385f995197f0d1cce11ce970 Mon Sep 17 00:00:00 2001
From: Raoul Jean Pierre Bonnal <ilpuccio.febo@gmail.com>
Date: Thu, 19 Jan 2017 19:54:59 +0100
Subject: [PATCH] gnu: Add r-fastica.

* gnu/packages/statistics.scm (r-fastica): New variable.
---
 gnu/packages/statistics.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index b4f8152b286..f27cb570426 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -4123,3 +4123,24 @@ (define-public r-lars
 modification efficiently implements epsilon Forward Stagewise linear
 regression.")
     (license license:gpl2)))
+
+(define-public r-fastica
+  (package
+    (name "r-fastica")
+    (version "1.2-0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "fastICA" version))
+       (sha256
+        (base32
+         "0ykk78fsk5da2g16i4wji85bvji7nayjvkfp07hyaxq9d15jmf0r"))))
+    (properties `((upstream-name . "fastICA")))
+    (build-system r-build-system)
+    (home-page "http://cran.r-project.org/web/packages/fastICA")
+    (synopsis "FastICA algorithms to perform ICA and projection pursuit")
+    (description
+     "This package provides an implementation of the FastICA algorithm to
+perform @dfn{independent component analysis} (ICA) and projection pursuit.")
+    ;; Any GPL version.
+    (license license:gpl3+)))
-- 
GitLab