From e5326da4f4111e991fa695d7d7b566d384f82895 Mon Sep 17 00:00:00 2001
From: David Thompson <dthompson2@worcester.edu>
Date: Sun, 26 Apr 2015 17:46:57 -0400
Subject: [PATCH] gnu: Add libical.

* gnu/packages/calendar.scm: New file.
* gnu-system.am (GNU_SYSTEM_MODULES): Add it.
---
 gnu-system.am             |  1 +
 gnu/packages/calendar.scm | 52 +++++++++++++++++++++++++++++++++++++++
 2 files changed, 53 insertions(+)
 create mode 100644 gnu/packages/calendar.scm

diff --git a/gnu-system.am b/gnu-system.am
index f6c99479236..0644a649a35 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -173,6 +173,7 @@ GNU_SYSTEM_MODULES =				\
   gnu/packages/libffcall.scm			\
   gnu/packages/libffi.scm			\
   gnu/packages/libftdi.scm			\
+  gnu/packages/calendar.scm			\
   gnu/packages/libidn.scm			\
   gnu/packages/libphidget.scm			\
   gnu/packages/libreoffice.scm			\
diff --git a/gnu/packages/calendar.scm b/gnu/packages/calendar.scm
new file mode 100644
index 00000000000..7e87fbbfe4c
--- /dev/null
+++ b/gnu/packages/calendar.scm
@@ -0,0 +1,52 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2015 David Thompson <davet@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages calendar)
+  #:use-module (gnu packages)
+  #:use-module (guix licenses)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix build-system cmake)
+  #:use-module (gnu packages icu4c)
+  #:use-module (gnu packages perl))
+
+(define-public libical
+  (package
+    (name "libical")
+    (version "1.0.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/libical/libical/releases/download/v"
+                    version "/libical-" version ".tar.gz"))
+              (sha256
+               (base32
+                "14lmjj63zyx88rf1z71l0v9ms4c2vpdhmixksjjxgywp5p2f7708"))))
+    (build-system cmake-build-system)
+    (arguments
+     '(#:tests? #f)) ; test suite appears broken
+    (native-inputs
+     `(("perl" ,perl)))
+    (inputs
+     `(("icu4c" ,icu4c)))
+    (home-page "https://libical.github.io/libical/")
+    (synopsis "iCalendar protocols and data formats implementation")
+    (description
+     "Libical is an implementation of the iCalendar protocols and protocol
+data units.")
+    (license lgpl2.1)))
-- 
GitLab