From e591a4d6e5db172f1595d665c6e477572c0d171c Mon Sep 17 00:00:00 2001
From: Ricardo Wurmus <rekado@elephly.net>
Date: Sat, 17 Oct 2015 10:10:07 +0200
Subject: [PATCH] gnu: non-sequencer: Disable SSE when not building on x86_64.

* gnu/packages/music.scm (non-sequencer)[arguments]: Add "--disable-sse"
  flag when not building on x86_64.
---
 gnu/packages/music.scm | 8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index fe8e6f129d8..a72f7543dde 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -274,7 +274,13 @@ (define-public non-sequencer
       (build-system waf-build-system)
       (arguments
        `(#:tests? #f ;no "check" target
-         #:configure-flags '("--project=sequencer")
+         #:configure-flags
+         (list "--project=sequencer"
+               ;; Disable the use of SSE unless on x86_64.
+               ,@(if (not (string-prefix? "x86_64" (or (%current-target-system)
+                                                       (%current-system))))
+                     '("--disable-sse")
+                     '()))
          #:python ,python-2))
       (inputs
        `(("jack" ,jack-1)
-- 
GitLab