From e5b648e06ace9623a368f1d8c18f35612f56ce79 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ludovic=20Court=C3=A8s?= <ludo@gnu.org>
Date: Fri, 18 Jul 2014 00:52:45 +0200
Subject: [PATCH] gnu: apr-util: Run 'make check' sequentially.

* gnu/packages/apr.scm (apr-util)[arguments]: Add #:parallel-tests?.
---
 gnu/packages/apr.scm | 8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/apr.scm b/gnu/packages/apr.scm
index 93609ad5ca6..26b49a57564 100644
--- a/gnu/packages/apr.scm
+++ b/gnu/packages/apr.scm
@@ -85,7 +85,13 @@ (define-public apr-util
              (system* "./configure"
                       (string-append "--prefix=" out)
                       (string-append "--with-apr=" apr)))))
-        %standard-phases)))
+        %standard-phases)
+
+       ;; There are race conditions during 'make check'.  Typically, the
+       ;; 'testall' executable is not built yet by the time 'make check' tries
+       ;; to run it.  See
+       ;; <http://lists.gnu.org/archive/html/guix-devel/2014-03/msg00261.html>.
+       #:parallel-tests? #f))
     (home-page "http://apr.apache.org/")
     (synopsis "One of the Apache Portable Runtime Library companions")
     (description
-- 
GitLab