From e5f1f5ce07f0976241ed1a68b952b40876eeafba Mon Sep 17 00:00:00 2001
From: Pierre Neidhardt <mail@ambrevar.xyz>
Date: Thu, 7 May 2020 09:58:56 +0200
Subject: [PATCH] gnu: warsow-qfusion: Remove bundled binaries and inputs.

* gnu/packages/game-development.scm (warsow-qfusion)[source]: Add snippet to
  remove unused bundled binaries and inputs.
---
 gnu/packages/game-development.scm | 8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 05cc152afd0..c63aac082a8 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -2246,7 +2246,13 @@ (define-public warsow-qfusion
                  (base32
                   "0xv2yycr43p3xmq7lm6j6zb3cpcr6w00x7qg918faq0mw9j7v48g"))
                 ;; Issue reported here: https://github.com/Warsow/qfusion/issues/46
-                (patches (search-patches "warsow-qfusion-fix-bool-return-type.patch"))))
+                (patches (search-patches "warsow-qfusion-fix-bool-return-type.patch"))
+                (modules '((guix build utils)))
+                (snippet '(begin
+                            (delete-file-recursively "platforms")
+                            (delete-file-recursively "debian")
+                            (delete-file-recursively "libsrcs")
+                            #t))))
       (build-system cmake-build-system)
       (arguments
        `(#:tests? #f                    ; No tests.
-- 
GitLab