diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index f04acc0a5c42be9164de9cba2641013aa97a77ba..0b6fbe5df28dc01f367e8706a69ef2e50efb62f0 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7338,6 +7338,29 @@ (define-public r-zlibbioc
 libraries for systems that do not have these available via other means.")
     (license license:artistic2.0)))
 
+(define-public r-r4rna
+  (package
+    (name "r-r4rna")
+    (version "0.1.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "http://www.e-rna.org/r-chie/files/R4RNA_"
+                           version ".tar.gz"))
+       (sha256
+        (base32
+         "1p0i78wh76jfgmn9jphbwwaz6yy6pipzfg08xs54cxavxg2j81p5"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-optparse" ,r-optparse)
+       ("r-rcolorbrewer" ,r-rcolorbrewer)))
+    (home-page "http://www.e-rna.org/r-chie/index.cgi")
+    (synopsis "Analysis framework for RNA secondary structure")
+    (description
+     "The R4RNA package aims to be a general framework for the analysis of RNA
+secondary structure and comparative analysis in R.")
+    (license license:gpl3+)))
+
 (define-public r-rhtslib
   (package
     (name "r-rhtslib")