From e78fd4ca636a19bc286747f8d91bda22cd8f08fd Mon Sep 17 00:00:00 2001
From: Andreas Enge <andreas@enge.fr>
Date: Sun, 13 Oct 2013 18:02:49 +0200
Subject: [PATCH] guix: Make cmake build system aware of usual paths.

*  guix/build/cmake-build-system.scm (configure): Set CMAKE_LIBRARY_PATH to
     LIBRARY_PATH and CMAKE_INCLUDE_PATH to CPATH.
---
 guix/build/cmake-build-system.scm | 2 ++
 1 file changed, 2 insertions(+)

diff --git a/guix/build/cmake-build-system.scm b/guix/build/cmake-build-system.scm
index 877d8110d76..449c6093980 100644
--- a/guix/build/cmake-build-system.scm
+++ b/guix/build/cmake-build-system.scm
@@ -38,6 +38,8 @@ (define* (configure #:key outputs (configure-flags '())
     (if (file-exists? "CMakeLists.txt")
         (let ((args `(,(string-append "-DCMAKE_INSTALL_PREFIX=" out)
                       ,@configure-flags)))
+          (setenv "CMAKE_LIBRARY_PATH" (getenv "LIBRARY_PATH"))
+          (setenv "CMAKE_INCLUDE_PATH" (getenv "CPATH"))
           (format #t "running 'cmake' with arguments ~s~%" args)
           (zero? (apply system* "cmake" args)))
         (error "no CMakeLists.txt found"))))
-- 
GitLab