From e8bdd73ac6739d11b93fc624d0a5275c7fedbc6d Mon Sep 17 00:00:00 2001
From: Andreas Enge <andreas@enge.fr>
Date: Tue, 11 Aug 2015 15:41:35 +0200
Subject: [PATCH] gnu: python-sip, python-pyqt: Fix computation of python
 library path.

* gnu/packages/qt.scm (python-sip, python2-sip, python-pyqt, python2-pyqt,
    python-pyqt-4, python2-pyqt-4)[arguments]: Fix computation of python
    library path for multi-digit python versions.
---
 gnu/packages/qt.scm | 41 ++++++++++++++++++++++++++++-------------
 1 file changed, 28 insertions(+), 13 deletions(-)

diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index eeb754200a8..ce5ab656a5b 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -339,6 +339,8 @@ (define-public python-sip
      `(("python" ,python-wrapper)))
     (arguments
      `(#:tests? #f ; no check target
+       #:modules ((srfi srfi-1)
+                  ,@%gnu-build-system-modules)
        #:phases
          (alist-replace
           'configure
@@ -346,12 +348,15 @@ (define-public python-sip
             (let* ((out (assoc-ref outputs "out"))
                    (bin (string-append out "/bin"))
                    (include (string-append out "/include"))
+                   (python (assoc-ref inputs "python"))
                    (python-version
-                     (string-take
-                       (string-take-right (assoc-ref inputs "python") 5)
-                       3))
+                     (last (string-split python #\-)))
+                   (python-major+minor
+                     (string-join
+                       (take (string-split python-version #\.) 2)
+                       "."))
                    (lib (string-append out "/lib/python"
-                                       python-version
+                                       python-major+minor
                                        "/site-packages")))
               (zero?
                 (system* "python" "configure.py"
@@ -402,7 +407,9 @@ (define-public python-pyqt
     (inputs
      `(("python" ,python-wrapper)))
     (arguments
-     `(#:phases
+     `(#:modules ((srfi srfi-1)
+                  ,@%gnu-build-system-modules)
+       #:phases
          (alist-replace
          'configure
          (lambda* (#:key inputs outputs #:allow-other-keys)
@@ -412,12 +419,15 @@ (define-public python-pyqt
                   (plugins (string-append out "/plugins"))
                   (designer (string-append plugins "/designer"))
                   (qml (string-append plugins "/PyQt5"))
+                  (python (assoc-ref inputs "python"))
                   (python-version
-                    (string-take
-                      (string-take-right (assoc-ref inputs "python") 5)
-                      3))
+                    (last (string-split python #\-)))
+                  (python-major+minor
+                    (string-join
+                      (take (string-split python-version #\.) 2)
+                      "."))
                   (lib (string-append out "/lib/python"
-                                      python-version
+                                      python-major+minor
                                       "/site-packages")))
              (zero? (system* "python" "configure.py"
                              "--confirm-license"
@@ -463,6 +473,8 @@ (define-public python-pyqt-4
        ("qt" ,qt-4)))
     (arguments
      `(#:tests? #f ; no check target
+       #:modules ((srfi srfi-1)
+                  ,@%gnu-build-system-modules)
        #:phases
          (alist-replace
          'configure
@@ -470,12 +482,15 @@ (define-public python-pyqt-4
            (let* ((out (assoc-ref outputs "out"))
                   (bin (string-append out "/bin"))
                   (sip (string-append out "/share/sip"))
+                  (python (assoc-ref inputs "python"))
                   (python-version
-                    (string-take
-                      (string-take-right (assoc-ref inputs "python") 5)
-                      3))
+                    (last (string-split python #\-)))
+                  (python-major+minor
+                    (string-join
+                      (take (string-split python-version #\.) 2)
+                      "."))
                   (lib (string-append out "/lib/python"
-                                      python-version
+                                      python-major+minor
                                       "/site-packages")))
              (zero? (system* "python" "configure.py"
                              "--confirm-license"
-- 
GitLab