diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 79de8a222b0249416b09464f3e3ad3c053a18f96..e941f8b2a09d7c52c0ad1b3eb78c7b788baf13a0 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -158,6 +158,7 @@ (define-public gst-plugins-base
        (base32
         "07ampnfa6p41s0lhia62l9h8bdx3c7vxvdz93pbx64m3wycq3gbp"))))
     (build-system gnu-build-system)
+    (outputs '("out" "doc"))
     (propagated-inputs
      `(("gstreamer" ,gstreamer))) ; required by gstreamer-plugins-base-1.0.pc
     (inputs
@@ -177,7 +178,11 @@ (define-public gst-plugins-base
         ("glib" ,glib "bin")
         ("python-wrapper" ,python-wrapper)))
     (arguments
-     '(#:phases
+     `(#:configure-flags
+       (list (string-append "--with-html-dir="
+                            (assoc-ref %outputs "doc")
+                            "/share/gtk-doc/html"))
+       #:phases
        (alist-cons-before
         'configure 'patch-test-pb-utils
         (lambda _