From ebc32b311088808d028804909c841154e5c8bc9f Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ludovic=20Court=C3=A8s?= <ludo@gnu.org>
Date: Mon, 11 Aug 2014 17:15:27 +0200
Subject: [PATCH] build: 'make clean' doesn't delete os-config.tmpl.

Fixes <http://bugs.gnu.org/18243>.
Reported by Andreas Enge and Mark H. Weaver.

* Makefile.am (EXAMPLES): New variable.
  (nobase_dist_guilemodule_DATA): Add it.
* gnu-system.am (GNU_SYSTEM_MODULES): Remove gnu/system/os-config.tmpl.
---
 Makefile.am   | 6 +++++-
 gnu-system.am | 1 -
 2 files changed, 5 insertions(+), 2 deletions(-)

diff --git a/Makefile.am b/Makefile.am
index ed11bcc7acc..6695e7e5b7c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -107,9 +107,13 @@ KCONFIGS =					\
   gnu/packages/linux-libre-i686.conf		\
   gnu/packages/linux-libre-x86_64.conf
 
+# Templates, examples.
+EXAMPLES =					\
+  gnu/system/os-config.tmpl
+
 GOBJECTS = $(MODULES:%.scm=%.go) guix/config.go
 
-nobase_dist_guilemodule_DATA = $(MODULES) $(KCONFIGS)
+nobase_dist_guilemodule_DATA = $(MODULES) $(KCONFIGS) $(EXAMPLES)
 nobase_nodist_guilemodule_DATA = $(GOBJECTS) guix/config.scm
 
 # Do we need to provide our own non-broken (srfi srfi-37) module?
diff --git a/gnu-system.am b/gnu-system.am
index 1f6240fa518..7928b525921 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -269,7 +269,6 @@ GNU_SYSTEM_MODULES =				\
   gnu/system/file-systems.scm			\
   gnu/system/grub.scm				\
   gnu/system/install.scm			\
-  gnu/system/os-config.tmpl			\
   gnu/system/linux.scm				\
   gnu/system/linux-initrd.scm			\
   gnu/system/shadow.scm				\
-- 
GitLab