From ec23833267ac859d3d45f65603e55415475126ba Mon Sep 17 00:00:00 2001
From: Tobias Geerinckx-Rice <me@tobias.gr>
Date: Fri, 31 Mar 2017 00:30:16 +0200
Subject: [PATCH] =?UTF-8?q?gnu:=20hdparm:=20Use=20=E2=80=98modify-phases?=
 =?UTF-8?q?=E2=80=99=20syntax.?=
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

* gnu/packages/linux.scm (hdparm): Use ‘modify-phases’.
---
 gnu/packages/linux.scm | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 7a9ecf0a00f..f801146cd6e 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2283,8 +2283,10 @@ (define-public hdparm
                       (list (string-append "binprefix=" out)
                             (string-append "manprefix=" out)
                             "CC=gcc"))
-       #:phases (alist-delete 'configure %standard-phases)
-       #:tests? #f))  ; no test suite
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure))           ; no configure script
+       #:tests? #f))                    ; no test suite
     (home-page "https://sourceforge.net/projects/hdparm/")
     (synopsis "View and tune ATA disk drive parameters")
     (description
-- 
GitLab