diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 8b73190d90658685bb01cf201391ec2d114618a4..3d677f2208feeadeecfc33a547f39240a0971711 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -393,11 +393,11 @@ (define-public util-linux
               (patches (list (search-patch "util-linux-tests.patch")))
               (modules '((guix build utils)))
               (snippet
-               ;; We take the 'logger' program from GNU Inetutils, so remove
-               ;; it from here.  There's no '--disable-logger', hence this
-               ;; hack.
+               ;; We take the 'logger' program from GNU Inetutils and 'kill'
+               ;; from GNU Coreutils.
                '(substitute* "configure"
-                  (("build_logger=yes") "build_logger=no")))))
+                  (("build_logger=yes") "build_logger=no")
+                  (("build_kill=yes") "build_kill=no")))))
     (build-system gnu-build-system)
     (arguments
      `(#:configure-flags '("--disable-use-tty-group"