diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 1c89424efd0494ec712952eb19db06951015e27d..148f8498c7bf7af7acf521ba660d248e74eabac5 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2151,10 +2151,10 @@ (define-public the-battle-for-wesnoth
 (define-public wesnoth
   (deprecated-package "wesnoth" the-battle-for-wesnoth))
 
-(define-public wesnoth-server
+(define-public the-battle-for-wesnoth-server
   (package
-    (inherit wesnoth)
-    (name "wesnoth-server")
+    (inherit the-battle-for-wesnoth)
+    (name "the-battle-for-wesnoth-server")
     (inputs
      `(("boost" ,boost)
        ("icu4c" ,icu4c)
@@ -2167,6 +2167,9 @@ (define-public wesnoth-server
     (description "This package contains a dedicated server for @emph{The
 Battle for Wesnoth}.")))
 
+(define-public wesnoth-server
+  (deprecated-package "wesnoth-server" the-battle-for-wesnoth-server))
+
 (define-public gamine
   (package
     (name "gamine")