From ecdb1348ad9992f7d98ea5b1b5b6bc0bafc9b79c Mon Sep 17 00:00:00 2001
From: Pierre Neidhardt <mail@ambrevar.xyz>
Date: Tue, 26 Mar 2019 13:37:38 +0100
Subject: [PATCH] gnu: wesnoth-server: Rename package to
 the-battle-for-wesnoth-server.

* gnu/packages/games.scm (wesnoth-server): Define in terms of
'deprecated-package'.
(the-battle-for-wesnoth-server): New variable, formerly known as "wesnoth-server".
---
 gnu/packages/games.scm | 9 ++++++---
 1 file changed, 6 insertions(+), 3 deletions(-)

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 1c89424efd0..148f8498c7b 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2151,10 +2151,10 @@ (define-public the-battle-for-wesnoth
 (define-public wesnoth
   (deprecated-package "wesnoth" the-battle-for-wesnoth))
 
-(define-public wesnoth-server
+(define-public the-battle-for-wesnoth-server
   (package
-    (inherit wesnoth)
-    (name "wesnoth-server")
+    (inherit the-battle-for-wesnoth)
+    (name "the-battle-for-wesnoth-server")
     (inputs
      `(("boost" ,boost)
        ("icu4c" ,icu4c)
@@ -2167,6 +2167,9 @@ (define-public wesnoth-server
     (description "This package contains a dedicated server for @emph{The
 Battle for Wesnoth}.")))
 
+(define-public wesnoth-server
+  (deprecated-package "wesnoth-server" the-battle-for-wesnoth-server))
+
 (define-public gamine
   (package
     (name "gamine")
-- 
GitLab