diff --git a/gnu/packages/regex.scm b/gnu/packages/regex.scm
index f526d1c2379f06a3be83195c56a0a10ef19179c6..bfd30278e9202701d329268818b7883bbb476984 100644
--- a/gnu/packages/regex.scm
+++ b/gnu/packages/regex.scm
@@ -91,9 +91,9 @@ (define-public tre
              ;; The tests require the availability of the
              ;; 'en_US.ISO-8859-1' locale.
              (setenv "LOCPATH" (getcwd))
-             (zero? (system* "localedef" "--no-archive"
-                             "--prefix" (getcwd) "-i" "en_US"
-                             "-f" "ISO-8859-1" "./en_US.ISO-8859-1")))))))
+             (invoke "localedef" "--no-archive"
+                     "--prefix" (getcwd) "-i" "en_US"
+                     "-f" "ISO-8859-1" "./en_US.ISO-8859-1"))))))
     (synopsis "Approximate regex matching library and agrep utility")
     (description "Superset of the POSIX regex API, enabling approximate
 matching.  Also ships a version of the agrep utility which behaves similar to