diff --git a/.gitignore b/.gitignore
index 7cc6751c7ec504603bfd7565abfb257bd867d680..755773567c8acd5218afa898964d64f99232a375 100644
--- a/.gitignore
+++ b/.gitignore
@@ -22,21 +22,23 @@ config.cache
 /m4/nls.m4
 /m4/po.m4
 /m4/progtest.m4
-/po/ChangeLog
-/po/Makefile.in.in
-/po/Makevars.template
-/po/POTFILES
-/po/Rules-quot
-/po/boldquot.sed
-/po/en@boldquot.header
-/po/en@quot.header
-/po/insert-header.sin
-/po/quot.sed
-/po/remove-potcdate.sin
-/po/stamp-po
-/po/guix.pot
-/po/*.mo
-/po/*.gmo
+/po/guix/ChangeLog
+/po/guix/Makefile.in.in
+/po/guix/Makevars.template
+/po/guix/POTFILES
+/po/guix/Rules-quot
+/po/guix/boldquot.sed
+/po/guix/en@boldquot.*
+/po/guix/en@quot.*
+/po/guix/insert-header.sin
+/po/guix/*.insert-header
+/po/guix/quot.sed
+/po/guix/remove-potcdate.sed
+/po/guix/remove-potcdate.sin
+/po/guix/stamp-po
+/po/guix/guix.pot
+/po/guix/*.mo
+/po/guix/*.gmo
 /tests/*.trs
 /INSTALL
 /m4/*
diff --git a/Makefile.am b/Makefile.am
index 84f8eb1b6392e339c7184cf452d4a2cbca8469ea..6c63c96345b2a43f28a95a82d084ff9f0e437f9f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -246,7 +246,7 @@ SUFFIXES = .go
 guix_install_go_files = install-nobase_nodist_guilemoduleDATA
 $(guix_install_go_files): install-nobase_dist_guilemoduleDATA
 
-SUBDIRS = po
+SUBDIRS = po/guix
 
 include doc.am
 
diff --git a/configure.ac b/configure.ac
index d65211779c64c4c76eba1ca5e57f73b7a99c27bd..398d8fc705c65258099d36bcec117cd2c1dbbbef 100644
--- a/configure.ac
+++ b/configure.ac
@@ -166,7 +166,7 @@ dnl See `HACKING' for more info.
 AM_MISSING_PROG([DOT], [dot])
 
 AC_CONFIG_FILES([Makefile
-                 po/Makefile.in
+                 po/guix/Makefile.in
 		 guix/config.scm])
 
 AC_CONFIG_FILES([scripts/guix], [chmod +x scripts/guix])
diff --git a/po/LINGUAS b/po/guix/LINGUAS
similarity index 100%
rename from po/LINGUAS
rename to po/guix/LINGUAS
diff --git a/po/Makevars b/po/guix/Makevars
similarity index 93%
rename from po/Makevars
rename to po/guix/Makevars
index d45ea4b9799937ddf9cdf2ec1387d0c3c71e7e30..3f85141efbb3fbb68f7ad5bf50730fad0504a466 100644
--- a/po/Makevars
+++ b/po/guix/Makevars
@@ -2,8 +2,8 @@
 
 DOMAIN = $(PACKAGE)
 
-subdir = po
-top_builddir = ..
+subdir = po/guix
+top_builddir = ../..
 
 # These options get passed to xgettext.  We want to catch standard
 # gettext uses, package synopses and descriptions, and SRFI-35 error
diff --git a/po/POTFILES.in b/po/guix/POTFILES.in
similarity index 100%
rename from po/POTFILES.in
rename to po/guix/POTFILES.in
diff --git a/po/eo.po b/po/guix/eo.po
similarity index 100%
rename from po/eo.po
rename to po/guix/eo.po
diff --git a/po/pt_BR.po b/po/guix/pt_BR.po
similarity index 100%
rename from po/pt_BR.po
rename to po/guix/pt_BR.po
diff --git a/po/sr.po b/po/guix/sr.po
similarity index 100%
rename from po/sr.po
rename to po/guix/sr.po
diff --git a/po/vi.po b/po/guix/vi.po
similarity index 100%
rename from po/vi.po
rename to po/guix/vi.po