diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index fc45805958e48bfe5dd47a6380cfa56cb262a465..ee4e7830b60071cef19f3f4780201d7f7b1c4656 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -460,6 +460,11 @@ (define-public lablgtk
        ("librsvg" ,librsvg)))
     (arguments
      `(#:tests? #f ; no check target
+
+       ;; Occasionally we would get "Error: Unbound module GtkThread" when
+       ;; compiling 'gtkThInit.ml', with 'make -j'.  So build sequentially.
+       #:parallel-build? #f
+
        #:phases
          (modify-phases %standard-phases
            (replace 'install