diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 479ae52ab0c146d2635e891f8207fe6dcd947228..1cd0df0dd0e37d8ff53550cba19c377fcd0dd344 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -8848,7 +8848,8 @@ (define-public hedgewars
      ;; XXX: Engine is built as Pascal source code, requiring Free Pascal
      ;; Compiler, which we haven't packaged yet.  With the flag below, we use
      ;; a Pascal to C translator and Clang instead.
-     `(#:configure-flags (list "-DBUILD_ENGINE_C=ON")
+     `(#:configure-flags (list "-DBUILD_ENGINE_C=ON"
+                               "-Dhaskell_flags=-dynamic;-fPIC")
        #:phases
        (modify-phases %standard-phases
          (replace 'check