From f3211ef3868326e3cec5318bc799a2ff6572741b Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ludovic=20Court=C3=A8s?= <ludo@gnu.org>
Date: Thu, 20 Jun 2013 22:49:34 +0200
Subject: [PATCH] build: Move Hydra recipe to build-aux/hydra.

* hydra.scm: Rename to...
* build-aux/hydra/gnu-system.scm: ... this.
* Makefile.am (EXTRA_DIST): Adjust accordingly.
---
 Makefile.am                                 | 2 +-
 hydra.scm => build-aux/hydra/gnu-system.scm | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)
 rename hydra.scm => build-aux/hydra/gnu-system.scm (98%)

diff --git a/Makefile.am b/Makefile.am
index f39e571581d..418b63a3777 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -127,7 +127,7 @@ EXTRA_DIST =					\
   ROADMAP					\
   TODO						\
   .dir-locals.el				\
-  hydra.scm					\
+  build-aux/hydra/gnu-system.scm		\
   build-aux/download.scm			\
   build-aux/sync-synopses.scm			\
   srfi/srfi-64.scm				\
diff --git a/hydra.scm b/build-aux/hydra/gnu-system.scm
similarity index 98%
rename from hydra.scm
rename to build-aux/hydra/gnu-system.scm
index c4b6dba924b..f03c201223b 100644
--- a/hydra.scm
+++ b/build-aux/hydra/gnu-system.scm
@@ -31,7 +31,7 @@
 
   (and=> (assoc-ref (current-source-location) 'filename)
          (lambda (file)
-           (let ((dir (dirname file)))
+           (let ((dir (string-append (dirname file) "/../..")))
              (format (current-error-port) "prepending ~s to the load path~%"
                      dir)
              (set! %load-path (cons dir %load-path))))))
-- 
GitLab