diff --git a/gnu/packages/markup.scm b/gnu/packages/markup.scm
index 56a920d873ad3ae4853fdf9dafe8a93a675f1592..95694367291751906152e72f5e74fcd1adbbe4c8 100644
--- a/gnu/packages/markup.scm
+++ b/gnu/packages/markup.scm
@@ -30,6 +30,7 @@ (define-module (gnu packages markup)
   #:use-module (guix build-system trivial)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system perl)
+  #:use-module (guix utils)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages)
   #:use-module (gnu packages perl)
@@ -138,7 +139,7 @@ (define-public discount
              #t))
          (replace 'configure
            (lambda* (#:key inputs outputs #:allow-other-keys)
-             (setenv "CC" "gcc")
+             (setenv "CC" ,(cc-for-target))
              (invoke "./configure.sh"
                      (string-append "--prefix=" (assoc-ref outputs "out"))
                      "--shared"))))))