From f41b56a92e8158f1fcb4cfef762783a6bab8a63d Mon Sep 17 00:00:00 2001
From: Tobias Geerinckx-Rice <me@tobias.gr>
Date: Wed, 7 Oct 2020 14:46:54 +0200
Subject: [PATCH] gnu: discount: Cross-compile.

* gnu/packages/markup.scm (discount)[arguments]: Use CC-FOR-TARGET.
---
 gnu/packages/markup.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/markup.scm b/gnu/packages/markup.scm
index 56a920d873a..95694367291 100644
--- a/gnu/packages/markup.scm
+++ b/gnu/packages/markup.scm
@@ -30,6 +30,7 @@ (define-module (gnu packages markup)
   #:use-module (guix build-system trivial)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system perl)
+  #:use-module (guix utils)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages)
   #:use-module (gnu packages perl)
@@ -138,7 +139,7 @@ (define-public discount
              #t))
          (replace 'configure
            (lambda* (#:key inputs outputs #:allow-other-keys)
-             (setenv "CC" "gcc")
+             (setenv "CC" ,(cc-for-target))
              (invoke "./configure.sh"
                      (string-append "--prefix=" (assoc-ref outputs "out"))
                      "--shared"))))))
-- 
GitLab