diff --git a/gnu/packages/screen.scm b/gnu/packages/screen.scm
index ae03220cc38fd3741eb8eadd90a8d7331696dd31..8fc17e18b0e08439eccdd5aeff028acaff122bc7 100644
--- a/gnu/packages/screen.scm
+++ b/gnu/packages/screen.scm
@@ -57,3 +57,34 @@ (define-public screen
 between them, to detach them from the current session, or even splitting the
 view to show two terminals at once.")
     (license gpl2+)))
+
+(define-public dtach
+  (package
+    (name "dtach")
+    (version "0.8")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://sourceforge/dtach/dtach-"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "1agjp08zxxxfni62sqx9qsd9526yqwlz7ry07lfq3clavyylwq8n"))))
+    (build-system gnu-build-system)
+    (arguments
+     ;; No install target.
+     '(#:phases (alist-replace
+                 'install
+                 (lambda* (#:key outputs #:allow-other-keys)
+                   (let ((out (assoc-ref outputs "out")))
+                     (mkdir-p (string-append out "/bin"))
+                     (copy-file "dtach" (string-append out "/bin/dtach"))))
+                 %standard-phases)
+       ;; No check target.
+       #:tests? #f))
+    (home-page "http://dtach.sourceforge.net/")
+    (synopsis "Emulates the detach feature of screen")
+    (description
+     "dtach is a tiny program that emulates the detach feature of screen,
+allowing you to run a program in an environment that is protected from the
+controlling terminal and attach to it later.")
+    (license gpl2+)))