diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 4039c1a00bb8d03f214269ea67aa814a48deef2b..b28608971360910cf56dea0ac1d7fc8eb68a184b 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -647,12 +647,15 @@ (define-public vigra
                              "/lib/python2.7/site-packages")
               ;; OpenEXR is not enabled by default.
               "-DWITH_OPENEXR=1"
+              ;; Fix rounding error on 32-bit machines
+              "-DCMAKE_C_FLAGS=-ffloat-store"
               ;; The header files of ilmbase are not found when included
               ;; by the header files of openexr, and an explicit flag
               ;; needs to be set.
               (string-append "-DCMAKE_CXX_FLAGS=-I"
                              (assoc-ref %build-inputs "ilmbase")
-                             "/include/OpenEXR"))))
+                             "/include/OpenEXR"
+                             " -ffloat-store"))))
    (synopsis "Computer vision library")
    (description
     "VIGRA stands for Vision with Generic Algorithms.  It is an image