From f803f775d244b4e3975ab42b9610d12b94f6e958 Mon Sep 17 00:00:00 2001
From: Leo Famulari <leo@famulari.name>
Date: Tue, 4 Oct 2016 10:28:37 -0400
Subject: [PATCH] gnu: vigra: Workaround rounding error in test suite on 32-bit
 CPUs.

* gnu/packages/image.scm (vigra)[arguments]: Pass '-ffloat-store' to
C_FLAGS and CXX_FLAGS.
---
 gnu/packages/image.scm | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 4039c1a00bb..b2860897136 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -647,12 +647,15 @@ (define-public vigra
                              "/lib/python2.7/site-packages")
               ;; OpenEXR is not enabled by default.
               "-DWITH_OPENEXR=1"
+              ;; Fix rounding error on 32-bit machines
+              "-DCMAKE_C_FLAGS=-ffloat-store"
               ;; The header files of ilmbase are not found when included
               ;; by the header files of openexr, and an explicit flag
               ;; needs to be set.
               (string-append "-DCMAKE_CXX_FLAGS=-I"
                              (assoc-ref %build-inputs "ilmbase")
-                             "/include/OpenEXR"))))
+                             "/include/OpenEXR"
+                             " -ffloat-store"))))
    (synopsis "Computer vision library")
    (description
     "VIGRA stands for Vision with Generic Algorithms.  It is an image
-- 
GitLab