diff --git a/gnu/packages/bash.scm b/gnu/packages/bash.scm
index d98ef0582b7154260cd8d20dda3743d303c5774f..02cb45c955199df22ecbbe610e18c0b6af3383bd 100644
--- a/gnu/packages/bash.scm
+++ b/gnu/packages/bash.scm
@@ -193,8 +193,8 @@ (define-public bash
         #:tests? #f
 
         #:phases (modify-phases %standard-phases
-                   (add-after install post-install ,post-install-phase)
-                   (add-after install install-headers
+                   (add-after 'install 'post-install ,post-install-phase)
+                   (add-after 'install 'install-headers
                               ,install-headers-phase))))
      (synopsis "The GNU Bourne-Again SHell")
      (description
diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
index ed9ba0e31f56222d5b35ad79d092dc66a3841d9d..9d2bde829d4b63450dc9675cad52461879f86fbd 100644
--- a/gnu/packages/code.scm
+++ b/gnu/packages/code.scm
@@ -142,8 +142,8 @@ (define-public sloccount
     (build-system gnu-build-system)
     (arguments
      '(#:phases (modify-phases %standard-phases
-                  (delete configure)
-                  (add-before build make-dotl-files-older
+                  (delete 'configure)
+                  (add-before 'build 'make-dotl-files-older
                               (lambda _
                                 ;; Make the '.l' files as old as the '.c'
                                 ;; files to avoid triggering the rule that
@@ -155,7 +155,7 @@ (define ref
                                             (set-file-time file ref))
                                           (find-files "." "\\.[chl]$"))
                                 #t))
-                  (add-before install make-target-directories
+                  (add-before 'install 'make-target-directories
                               (lambda* (#:key outputs #:allow-other-keys)
                                 (let ((out (assoc-ref outputs "out")))
                                   (mkdir-p (string-append out "/bin"))
@@ -163,7 +163,7 @@ (define ref
                                                           "/share/man/man1"))
                                   (mkdir-p (string-append out
                                                           "/share/doc")))))
-                  (replace check
+                  (replace 'check
                            (lambda _
                              (setenv "HOME" (getcwd))
                              (setenv "PATH"
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index dc90a1231de934a709ff7d13a4778c30e0c3cbdc..66f172927f08fcad7c614fa0b8d35bfdee3b29d0 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -149,7 +149,7 @@ (define-public s2tc
     (arguments
      '(#:phases
        (modify-phases %standard-phases
-         (add-after unpack autogen
+         (add-after 'unpack 'autogen
           (lambda _
             (zero? (system* "sh" "autogen.sh")))))))
     (home-page "https://github.com/divVerent/s2tc")
@@ -282,10 +282,10 @@ (define-public mesa-headers
     (arguments
      '(#:phases
        (modify-phases %standard-phases
-         (delete configure)
-         (delete build)
-         (delete check)
-         (replace install
+         (delete 'configure)
+         (delete 'build)
+         (delete 'check)
+         (replace 'install
                   (lambda* (#:key outputs #:allow-other-keys)
                     (copy-recursively "include" (string-append
                                                  (assoc-ref outputs "out")
@@ -318,7 +318,7 @@ (define-public mesa-utils
      '(#:phases
        (modify-phases %standard-phases
          (replace
-          install
+          'install
           (lambda* (#:key outputs #:allow-other-keys)
             (let ((out (assoc-ref outputs "out")))
               (mkdir-p (string-append out "/bin"))
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 0e674da899ece36701dd2824fb85cc2e562fcfb6..bf19b9ec823c3e85b3f8ebf81114195c9d19f14d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1639,11 +1639,11 @@ (define-public gnome-mines
     (arguments
      '(#:phases
        (modify-phases %standard-phases
-         (add-before configure patch-/bin/true
+         (add-before 'configure 'patch-/bin/true
                      (lambda _
                        (substitute* "configure"
                          (("/bin/true") (which "true")))))
-         (add-after install wrap-pixbuf
+         (add-after 'install 'wrap-pixbuf
                     ;; Use librsvg's loaders.cache to support SVG files.
                     (lambda* (#:key inputs outputs #:allow-other-keys)
                       (let* ((out    (assoc-ref outputs "out"))
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index f574628698945eb76831b0f21924c872c073d983..14badc949ca43fc3ffb0e064c32be2e8ae202a88 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -181,14 +181,14 @@ (define-public brdf-explorer
     (build-system gnu-build-system)
     (arguments
      `(#:phases (modify-phases %standard-phases
-                  (replace configure
+                  (replace 'configure
                            (lambda* (#:key outputs #:allow-other-keys)
                              (let ((out (assoc-ref outputs "out")))
                                (chdir "trunk")
                                (zero? (system* "qmake"
                                                (string-append
                                                 "prefix=" out))))))
-                  (add-after install wrap-program
+                  (add-after 'install 'wrap-program
                              (lambda* (#:key outputs #:allow-other-keys)
                                (let* ((out (assoc-ref outputs "out"))
                                       (bin (string-append out "/bin"))
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 93dd2ac4e631921eb1bbb0be18300caf22d83ede..ece0e8c54a0cee637f84542622fd0d15c9d78594 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -204,11 +204,11 @@ (define-public leptonica
        (modify-phases %standard-phases
          ;; Prevent make from trying to regenerate config.h.in.
          (add-after
-          unpack set-config-h-in-file-time
+          'unpack 'set-config-h-in-file-time
           (lambda _
             (set-file-time "config/config.h.in" (stat "configure"))))
          (add-after
-          unpack patch-reg-wrapper
+          'unpack 'patch-reg-wrapper
           (lambda _
             (substitute* "prog/reg_wrapper.sh"
               ((" /bin/sh ")
diff --git a/gnu/packages/key-mon.scm b/gnu/packages/key-mon.scm
index d29f30258d83f02e9af47076c3450268ca4f2b57..c890f85f8d67fb7ab4c2f1fa9d8e1615265db325 100644
--- a/gnu/packages/key-mon.scm
+++ b/gnu/packages/key-mon.scm
@@ -42,7 +42,7 @@ (define-public key-mon
     (arguments
      `(#:python ,python-2                    ;uses the Python 2 'print' syntax
        #:phases (modify-phases %standard-phases
-                  (add-after install wrap
+                  (add-after 'install 'wrap
                              (lambda* (#:key inputs outputs #:allow-other-keys)
                                (let* ((out  (assoc-ref outputs "out"))
                                       (bin  (string-append out "/bin"))
diff --git a/gnu/packages/ocr.scm b/gnu/packages/ocr.scm
index 32da42b95ff372510563ffd5bde11cf623381097..b94a7f51cb0dd0028c14d4ffe63bdf4cea8600c2 100644
--- a/gnu/packages/ocr.scm
+++ b/gnu/packages/ocr.scm
@@ -76,7 +76,7 @@ (define-public tesseract-ocr
      '(#:phases
        (modify-phases %standard-phases
          (add-after
-          unpack autogen
+          'unpack 'autogen
           (lambda _
             (zero? (system* "sh" "autogen.sh")))))
        #:configure-flags
diff --git a/gnu/packages/plotutils.scm b/gnu/packages/plotutils.scm
index 245dfe9c674e425a6e002a0bed2c859c70e601fc..6166226dce0e37d123402df7a71058eff5008b60 100644
--- a/gnu/packages/plotutils.scm
+++ b/gnu/packages/plotutils.scm
@@ -118,13 +118,13 @@ (define-public ploticus
      '(#:tests? #f
        #:phases
        (modify-phases %standard-phases
-         (replace configure (lambda _ (chdir "src")))
-         (add-before install make-target-directories
+         (replace 'configure (lambda _ (chdir "src")))
+         (add-before 'install 'make-target-directories
                      (lambda* (#:key outputs #:allow-other-keys)
                        (let ((out (assoc-ref outputs "out")))
                          (mkdir-p (string-append out "/bin"))
                          #t)))
-         (add-after install install-prefabs
+         (add-after 'install 'install-prefabs
                     (lambda* (#:key outputs #:allow-other-keys)
                       (let* ((out (assoc-ref outputs "out"))
                              (dir (string-append out
diff --git a/gnu/packages/search.scm b/gnu/packages/search.scm
index d1133248df0ff97fcc456c7431deb930071c89fb..4a4ad207590eed6bb96bae07803663f12a3d1876 100644
--- a/gnu/packages/search.scm
+++ b/gnu/packages/search.scm
@@ -76,10 +76,10 @@ (define-public libtocc
     (arguments
      `(#:phases (modify-phases %standard-phases
                   (add-before
-                   configure chdir-source
+                   'configure 'chdir-source
                    (lambda _ (chdir "libtocc/src")))
                   (replace
-                   check
+                   'check
                    (lambda _
                      (with-directory-excursion "../tests"
                        (and (zero? (system* "./configure"
@@ -113,7 +113,7 @@ (define-public tocc
      `(#:tests? #f                      ;No tests
        #:phases (modify-phases %standard-phases
                   (add-after
-                   unpack chdir-source
+                   'unpack 'chdir-source
                    (lambda _ (chdir "cli/src"))))))
     (home-page "http://t-o-c-c.com/")
     (synopsis "Command-line interface to libtocc")
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index bc589a6edbb0b66c7602e93416665d5085a0fc2d..8223a3fa70d9b9e4135b7544b57d1b6dfd5a86eb 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -738,12 +738,12 @@ (define-public mpv
      '(#:phases
        (modify-phases %standard-phases
          (add-before
-          configure setup-waf
+          'configure 'setup-waf
           (lambda* (#:key inputs #:allow-other-keys)
             (copy-file (assoc-ref inputs "waf") "waf")
             (setenv "CC" "gcc")))
          (add-before
-          configure patch-wscript
+          'configure 'patch-wscript
           (lambda* (#:key inputs #:allow-other-keys)
             (substitute* "wscript"
               ;; XXX Remove this when our Samba package provides a .pc file.
@@ -1219,7 +1219,7 @@ (define-public vapoursynth
      '(#:phases
        (modify-phases %standard-phases
          (add-after
-          unpack autogen
+          'unpack 'autogen
           (lambda _
             (zero? (system* "sh" "autogen.sh")))))))
     (home-page "http://www.vapoursynth.com/")
diff --git a/guix/build/cmake-build-system.scm b/guix/build/cmake-build-system.scm
index d8d437c6531bd36dfe1da9db9bc86c373880a493..f57622e0f4ce206ac1d28035e14232e30d8ea855 100644
--- a/guix/build/cmake-build-system.scm
+++ b/guix/build/cmake-build-system.scm
@@ -73,8 +73,8 @@ (define %standard-phases
   ;; Everything is as with the GNU Build System except for the `configure'
   ;; and 'check' phases.
   (modify-phases gnu:%standard-phases
-    (replace check check)
-    (replace configure configure)))
+    (replace 'check check)
+    (replace 'configure configure)))
 
 (define* (cmake-build #:key inputs (phases %standard-phases)
                       #:allow-other-keys #:rest args)
diff --git a/guix/build/glib-or-gtk-build-system.scm b/guix/build/glib-or-gtk-build-system.scm
index c57bc3e731527f4e2363e660334efa57121d57dc..9c0104365daf1232fb5f0c6d7f2bfb81678904b2 100644
--- a/guix/build/glib-or-gtk-build-system.scm
+++ b/guix/build/glib-or-gtk-build-system.scm
@@ -240,9 +240,9 @@ (define* (generate-icon-cache #:key outputs #:allow-other-keys)
 
 (define %standard-phases
   (modify-phases gnu:%standard-phases
-    (add-after install glib-or-gtk-compile-schemas compile-glib-schemas)
-    (add-after install glib-or-gtk-icon-cache generate-icon-cache)
-    (add-after install glib-or-gtk-wrap wrap-all-programs)))
+    (add-after 'install 'glib-or-gtk-compile-schemas compile-glib-schemas)
+    (add-after 'install 'glib-or-gtk-icon-cache generate-icon-cache)
+    (add-after 'install 'glib-or-gtk-wrap wrap-all-programs)))
 
 (define* (glib-or-gtk-build #:key inputs (phases %standard-phases)
                             #:allow-other-keys #:rest args)
diff --git a/guix/build/gnu-dist.scm b/guix/build/gnu-dist.scm
index 887b5e94e9401d7fa7ac7603141e894869697f07..ad69c6cf16a7aa8dd88e63f1db7bff9aa42e146e 100644
--- a/guix/build/gnu-dist.scm
+++ b/guix/build/gnu-dist.scm
@@ -83,10 +83,10 @@ (define* (install-dist #:key outputs #:allow-other-keys)
 (define %dist-phases
   ;; Phases for building a source tarball.
   (modify-phases %standard-phases
-    (delete strip)
-    (replace install install-dist)
-    (replace build build)
-    (add-before configure autoreconf autoreconf)
-    (replace unpack copy-source)))
+    (delete 'strip)
+    (replace 'install install-dist)
+    (replace 'build build)
+    (add-before 'configure 'autoreconf autoreconf)
+    (replace 'unpack copy-source)))
 
 ;;; gnu-dist.scm ends here
diff --git a/guix/build/perl-build-system.scm b/guix/build/perl-build-system.scm
index 9ca5353bb98c93cd7b87f3006f0fc17ed58950f0..8f480eae16accccd7a87cf825a99ecb55e1556d6 100644
--- a/guix/build/perl-build-system.scm
+++ b/guix/build/perl-build-system.scm
@@ -72,10 +72,10 @@ (define %standard-phases
   ;; Everything is as with the GNU Build System except for the `configure',
   ;; `build', `check', and `install' phases.
   (modify-phases gnu:%standard-phases
-    (replace install install)
-    (replace check check)
-    (replace build build)
-    (replace configure configure)))
+    (replace 'install install)
+    (replace 'check check)
+    (replace 'build build)
+    (replace 'configure configure)))
 
 (define* (perl-build #:key inputs (phases %standard-phases)
                      #:allow-other-keys #:rest args)
diff --git a/guix/build/python-build-system.scm b/guix/build/python-build-system.scm
index 9f853134bde063233ed642ccf977ea9b4cf75203..26a7254db9b79e2df52185de5f726a2bb08eba92 100644
--- a/guix/build/python-build-system.scm
+++ b/guix/build/python-build-system.scm
@@ -123,12 +123,12 @@ (define %standard-phases
   ;; 'configure' and 'build' phases are not needed.  Everything is done during
   ;; 'install'.
   (modify-phases gnu:%standard-phases
-    (delete configure)
-    (replace install install)
-    (replace check check)
-    (replace build build)
-    (add-after install wrap wrap)
-    (add-before strip rename-pth-file rename-pth-file)))
+    (delete 'configure)
+    (replace 'install install)
+    (replace 'check check)
+    (replace 'build build)
+    (add-after 'install 'wrap wrap)
+    (add-before 'strip 'rename-pth-file rename-pth-file)))
 
 (define* (python-build #:key inputs (phases %standard-phases)
                        #:allow-other-keys #:rest args)
diff --git a/guix/build/ruby-build-system.scm b/guix/build/ruby-build-system.scm
index a143df467fa8a8652f00a970438749f38845b14d..531cf382aeefaba3f13796e01bbdea496e499ee5 100644
--- a/guix/build/ruby-build-system.scm
+++ b/guix/build/ruby-build-system.scm
@@ -72,11 +72,11 @@ (define* (install #:key source inputs outputs #:allow-other-keys)
 
 (define %standard-phases
   (modify-phases gnu:%standard-phases
-    (delete configure)
-    (add-after unpack gitify gitify)
-    (replace build build)
-    (replace install install)
-    (replace check check)))
+    (delete 'configure)
+    (add-after 'unpack 'gitify gitify)
+    (replace 'build build)
+    (replace 'install install)
+    (replace 'check check)))
 
 (define* (ruby-build #:key inputs (phases %standard-phases)
                      #:allow-other-keys #:rest args)
diff --git a/guix/build/utils.scm b/guix/build/utils.scm
index a5a6167a8c6711c70c80af361fcbbccee9554490..5d5566d1e334c2c283e80901a0248ccd2aceed3c 100644
--- a/guix/build/utils.scm
+++ b/guix/build/utils.scm
@@ -446,13 +446,13 @@ (define-syntax-rule (modify-phases phases mod-spec ...)
 (define-syntax %modify-phases
   (syntax-rules (delete replace add-before add-after)
     ((_ phases (delete old-phase-name))
-     (alist-delete 'old-phase-name phases))
+     (alist-delete old-phase-name phases))
     ((_ phases (replace old-phase-name new-phase))
-     (alist-replace 'old-phase-name new-phase phases))
+     (alist-replace old-phase-name new-phase phases))
     ((_ phases (add-before old-phase-name new-phase-name new-phase))
-     (alist-cons-before 'old-phase-name 'new-phase-name new-phase phases))
+     (alist-cons-before old-phase-name new-phase-name new-phase phases))
     ((_ phases (add-after old-phase-name new-phase-name new-phase))
-     (alist-cons-after 'old-phase-name 'new-phase-name new-phase phases))))
+     (alist-cons-after old-phase-name new-phase-name new-phase phases))))
 
 
 ;;;
diff --git a/guix/build/waf-build-system.scm b/guix/build/waf-build-system.scm
index d172c5a83660f2b98345bec99e1a3f46033f13d6..85f0abcfd6262eb971ae9b2fe287b4dc38774d80 100644
--- a/guix/build/waf-build-system.scm
+++ b/guix/build/waf-build-system.scm
@@ -70,10 +70,10 @@ (define* (install #:key outputs inputs (configure-flags '())
 
 (define %standard-phases
   (modify-phases gnu:%standard-phases
-    (replace configure configure)
-    (replace build build)
-    (replace check check)
-    (replace install install)))
+    (replace 'configure configure)
+    (replace 'build build)
+    (replace 'check check)
+    (replace 'install install)))
 
 (define* (waf-build #:key inputs (phases %standard-phases)
                        #:allow-other-keys #:rest args)