From f99f6fd6fa5c55f490fad7f4e444ef8a835db2ac Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ludovic=20Court=C3=A8s?= <ludo@gnu.org>
Date: Mon, 19 Aug 2013 00:52:49 +0200
Subject: [PATCH] gnu: Add GNU Ocrad.

* gnu/packages/ocrad.scm: New file.
* gnu-system.am (GNU_SYSTEM_MODULES): Add it.
---
 gnu-system.am          |  1 +
 gnu/packages/ocrad.scm | 53 ++++++++++++++++++++++++++++++++++++++++++
 2 files changed, 54 insertions(+)
 create mode 100644 gnu/packages/ocrad.scm

diff --git a/gnu-system.am b/gnu-system.am
index 926bb9672d8..552ef62b5b4 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -120,6 +120,7 @@ GNU_SYSTEM_MODULES =				\
   gnu/packages/nettle.scm			\
   gnu/packages/noweb.scm			\
   gnu/packages/ocaml.scm			\
+  gnu/packages/ocrad.scm			\
   gnu/packages/oggvorbis.scm			\
   gnu/packages/openldap.scm			\
   gnu/packages/openssl.scm			\
diff --git a/gnu/packages/ocrad.scm b/gnu/packages/ocrad.scm
new file mode 100644
index 00000000000..f6bc112a8c2
--- /dev/null
+++ b/gnu/packages/ocrad.scm
@@ -0,0 +1,53 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages ocrad)
+  #:use-module (guix licenses)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix build-system gnu)
+  #:use-module ((gnu packages compression)
+                #:select (lzip)))
+
+(define-public ocrad
+  (package
+    (name "ocrad")
+    (version "0.22")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append "mirror://gnu/ocrad/ocrad-"
+                                 version ".tar.lz"))
+             (sha256
+              (base32
+               "1zcqa4ydcmmhzyg730wywnmkjv2x2av3r875vwz69k69yjydrjfn"))))
+    (build-system gnu-build-system)
+    (native-inputs `(("lzip" ,lzip)))
+    (home-page "http://www.gnu.org/software/ocrad/")
+    (synopsis "Optical character recognition based on feature extraction")
+    (description
+     "GNU Ocrad is an OCR (Optical Character Recognition) program based on a
+feature extraction method.  It reads images in pbm (bitmap), pgm
+ (greyscale) or ppm (color) formats and produces text in byte (8-bit)
+or UTF-8 formats.
+
+Also includes a layout analyser able to separate the columns or blocks of text
+normally found on printed pages.
+
+Ocrad can be used as a stand-alone console application, or as a backend to
+other programs.")
+    (license gpl3+)))
-- 
GitLab