From f9e62ad221a9f059f78b4f2800d48cf893de10dd Mon Sep 17 00:00:00 2001
From: Ricardo Wurmus <ricardo.wurmus@mdc-berlin.de>
Date: Tue, 10 Mar 2015 13:56:55 +0100
Subject: [PATCH] gnu: icedtea6: patch ant shebang in unpack phase

* gnu/packages/java.scm (icedtea6)[arguments]: patch bootstrap ant in the
  `unpack' phase instead of `patch-paths'.
---
 gnu/packages/java.scm | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 29f628ca38a..7f841f090bb 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -184,6 +184,7 @@ (define-public icedtea6
                (zero? (system* "tar" "xvjf"
                                (assoc-ref inputs "ant-bootstrap")))
                (begin
+                 (patch-shebang "apache-ant-1.9.4/bin/ant")
                  (chdir (string-append ,name "-" ,version))
                  (mkdir "openjdk")
                  (with-directory-excursion "openjdk"
@@ -193,8 +194,6 @@ (define-public icedtea6
         (alist-cons-after
          'unpack 'patch-paths
          (lambda _
-           (patch-shebang "../apache-ant-1.9.4/bin/ant")
-
            ;; shebang in patches so that they apply cleanly
            (substitute* '("patches/jtreg-jrunscript.patch"
                           "patches/hotspot/hs23/drop_unlicensed_test.patch")
-- 
GitLab