From fb0b645658041c3061d2f70dc1a11a100f569217 Mon Sep 17 00:00:00 2001
From: Efraim Flashner <efraim@flashner.co.il>
Date: Sat, 1 Dec 2018 18:48:41 +0200
Subject: [PATCH] gnu: vim-fugitive: Update to 2.5.

* gnu/packages/vim.scm (vim-fugitive): Update to 2.5.
[arguments]: Also install the autoload and ftdetect folders.
---
 gnu/packages/vim.scm | 8 ++++++--
 1 file changed, 6 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 28d20af0235..ecce4e0ae63 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -459,7 +459,7 @@ (define-public vim-context-filetype
 (define-public vim-fugitive
   (package
     (name "vim-fugitive")
-    (version "2.3")
+    (version "2.5")
     (source
       (origin
         (method git-fetch)
@@ -469,7 +469,7 @@ (define-public vim-fugitive
         (file-name (git-file-name name version))
         (sha256
          (base32
-          "17s94a8g5z0lrs7yy4nyqyvp9ykys5ws2ar3m3c0bjsn0iazd7m3"))))
+          "17yz7gxn7a49jzndr4z5vnk1y4a6c22qss3mwxzmq4m46fni0k8q"))))
     (build-system gnu-build-system)
     (arguments
      '(#:tests? #f
@@ -481,9 +481,13 @@ (define-public vim-fugitive
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))
                     (vimfiles (string-append out "/share/vim/vimfiles"))
+                    (autoload (string-append vimfiles "/autoload"))
                     (doc (string-append vimfiles "/doc"))
+                    (ftdetect (string-append vimfiles "/ftdetect"))
                     (plugin (string-append vimfiles "/plugin")))
+               (copy-recursively "autoload" autoload)
                (copy-recursively "doc" doc)
+               (copy-recursively "ftdetect" ftdetect)
                (copy-recursively "plugin" plugin)
                #t))))))
     (home-page "https://github.com/tpope/vim-fugitive")
-- 
GitLab