From fb634a0e0b21864f1b3d3ab66336ea6c2cebdeb8 Mon Sep 17 00:00:00 2001
From: nixo <nicolo@nixo.xyz>
Date: Tue, 19 Jan 2021 00:01:28 +0100
Subject: [PATCH] gnu: Add julia-offsetarrays.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

* gnu/packages/julia-xyz.scm (julia-offsetarrays): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
---
 gnu/packages/julia-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 2e0efb0b5a2..3dd731ef288 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -147,6 +147,31 @@ (define-public julia-orderedcollections
 which they were added to the collection.")
     (license license:expat)))
 
+(define-public julia-offsetarrays
+  (package
+    (name "julia-offsetarrays")
+    (version "1.5.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/JuliaArrays/OffsetArrays.jl")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1y3fnssw2hzyghrk6jfcxslab0f8sjkjszh482snfq4k6mkrhy77"))))
+    (build-system julia-build-system)
+    (propagated-inputs
+     `(("julia-adapt" ,julia-adapt)))
+    ;; CatIndices depends on OffsetArrays, introducing a recursive dependency
+    (arguments '(#:tests? #f))
+    (home-page "https://juliaarrays.github.io/OffsetArrays.jl/stable/")
+    (synopsis "Fortran-like arrays with arbitrary, zero or negative indices")
+    (description "@code{OffsetArrays.jl} provides Julia users with arrays that
+have arbitrary indices, similar to those found in some other programming
+languages like Fortran.")
+    (license license:expat)))
+
 (define-public julia-parsers
   (package
     (name "julia-parsers")
-- 
GitLab