diff --git a/gnu/packages/tor.scm b/gnu/packages/tor.scm
index 4a391005117bd54e0a43828cdbe7e245bd94e39b..f598672d918ede5ef0263eb0d5aa064166dbc0e9 100644
--- a/gnu/packages/tor.scm
+++ b/gnu/packages/tor.scm
@@ -146,7 +146,8 @@ (define-public privoxy
            (lambda _
              ;; Unfortunately, this is not a tarball produced by
              ;; "make dist".
-             (zero? (system* "autoreconf" "-vfi")))))
+             (invoke "autoreconf" "-vfi")
+             #t)))
        #:tests? #f))
     (inputs
      `(("w3m" ,w3m)