From fbd1c3e95b35b354eb6230843b7e3ae61619cabe Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ludovic=20Court=C3=A8s?= <ludo@gnu.org>
Date: Fri, 27 Sep 2013 00:33:15 +0200
Subject: [PATCH] gnu: linux-initrd: Mount /tmp as a tmpfs.

* gnu/packages/linux-initrd.scm (gnu-system-initrd): Make sure /root/tmp
  exists; mount it as a tmpfs.
---
 gnu/packages/linux-initrd.scm | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/linux-initrd.scm b/gnu/packages/linux-initrd.scm
index b62843aadd0..ed30fa56b16 100644
--- a/gnu/packages/linux-initrd.scm
+++ b/gnu/packages/linux-initrd.scm
@@ -363,8 +363,7 @@ (define-public gnu-system-initrd
         (make-essential-device-nodes)
 
         ;; Prepare the real root file system under /root.
-        (unless (file-exists? "/root")
-          (mkdir "/root"))
+        (mkdir-p "/root")
         (if root
             ;; Assume ROOT has a usable /dev tree.
             (mount root "/root" "ext3")
@@ -374,6 +373,9 @@ (define-public gnu-system-initrd
 
         (mount-essential-file-systems #:root "/root")
 
+        (mkdir-p "/root/tmp")
+        (mount "none" "/root/tmp" "tmpfs")
+
         ;; XXX: We don't copy our fellow Guile modules to /root (see
         ;; 'qemu-initrd'), so if TO-LOAD tries to load a module (which can
         ;; happen if it throws, to display the exception!), then we're
-- 
GitLab