diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index fbf80226f66b063617849005c47702244e3eda44..789b11e944cbea8a591acc4f519fab6bcebba2d7 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -539,14 +539,14 @@ (define-public libodfgen
 (define-public libmwaw
   (package
     (name "libmwaw")
-    (version "0.3.4")
+    (version "0.3.5")
     (source
      (origin
       (method url-fetch)
       (uri (string-append "mirror://sourceforge/" name "/" name "/"
                           name "-" version ".tar.xz"))
       (sha256 (base32
-               "1sn95flxrh85qjsg1kk700c1ggxaaccr9j1nnw7x4daw8lky25ac"))))
+               "1vx9h419fcfcs0yj071hsg9d2qvkacgca6052m8hv3h743cdmzil"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("doxygen" ,doxygen)