diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index d7b35834fe9204eb87298f96ff0f865f10abec51..0fa6d451ed39ad70a357bc100ded6689d7a1d547 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -2868,6 +2868,14 @@ (define-public mongo-tools
                (delete-file-recursively
                 "src/github.com/mongodb/mongo-tools/vendor")
                #t))
+           (add-after 'delete-bundled-source-code 'patch-source
+             (lambda _
+               ;; Remove a redundant argument that causes compilation to fail.
+               (substitute*
+                   "src/github.com/mongodb/mongo-tools/mongorestore/filepath.go"
+                 (("skipping restore of system.profile collection\", db)")
+                  "skipping restore of system.profile collection\")"))
+               #t))
            ;; We don't need to install the source code for end-user applications
            (delete 'install-source)
            (replace 'build