From fe5969656adc0c799deaf06d90a9628b78e7b232 Mon Sep 17 00:00:00 2001
From: Christopher Baines <mail@cbaines.net>
Date: Tue, 4 Dec 2018 20:22:27 +0000
Subject: [PATCH] gnu: mongo-tools: Fix build.

I guess this broke when upgrading go. I did try upgrading to the later patch
and minor releases, but they had similar problems, so lets upgrade separately.

* gnu/packages/databases.scm (mongo-tools)[arguments]: Add patch-source phase.
---
 gnu/packages/databases.scm | 8 ++++++++
 1 file changed, 8 insertions(+)

diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index d7b35834fe9..0fa6d451ed3 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -2868,6 +2868,14 @@ (define-public mongo-tools
                (delete-file-recursively
                 "src/github.com/mongodb/mongo-tools/vendor")
                #t))
+           (add-after 'delete-bundled-source-code 'patch-source
+             (lambda _
+               ;; Remove a redundant argument that causes compilation to fail.
+               (substitute*
+                   "src/github.com/mongodb/mongo-tools/mongorestore/filepath.go"
+                 (("skipping restore of system.profile collection\", db)")
+                  "skipping restore of system.profile collection\")"))
+               #t))
            ;; We don't need to install the source code for end-user applications
            (delete 'install-source)
            (replace 'build
-- 
GitLab