Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
0297a160
Unverified
Commit
0297a160
authored
7 years ago
by
Danny Milosavljevic
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add me-cleaner.
* gnu/packages/flashing-tools.scm (me-cleaner): New variable.
parent
9721c0b6
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/flashing-tools.scm
+32
-0
32 additions, 0 deletions
gnu/packages/flashing-tools.scm
with
32 additions
and
0 deletions
gnu/packages/flashing-tools.scm
+
32
−
0
View file @
0297a160
...
...
@@ -31,6 +31,7 @@ (define-module (gnu packages flashing-tools)
#
:use-module
(
gnu
packages
)
#
:use-module
(
guix
build-system
cmake
)
#
:use-module
(
guix
build-system
gnu
)
#
:use-module
(
guix
build-system
python
)
#
:use-module
(
gnu
packages
bison
)
#
:use-module
(
gnu
packages
compression
)
#
:use-module
(
gnu
packages
flex
)
...
...
@@ -402,3 +403,34 @@ (define-public intelmetool
@code{sudo rmmod mei} before using this tool. Also pass
@code{iomem=relaxed} to the Linux kernel command line."
)
(
license
license:gpl2
)))
(
define-public
me-cleaner
(
package
(
name
"me-cleaner"
)
(
version
"1.1"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"https://github.com/corna/me_cleaner/"
"archive/v"
version
".tar.gz"
))
(
sha256
(
base32
"1pgwdqy0jly80nhxmlmyibs343497yjzs6dwfbkcw0l1gjm8i5hw"
))
(
file-name
(
string-append
name
"-"
version
".tar.gz"
))))
(
build-system
python-build-system
)
(
arguments
`
(
#
:phases
(
modify-phases
%standard-phases
(
add-after
'unpack
'create-setup
.
py
(
lambda
_
(
call-with-output-file
"setup.py"
(
lambda
(
port
)
(
format
port
"\
from setuptools import setup
setup(name='me_cleaner', version='~a', scripts=['me_cleaner.py'])
"
,
version
)))
#t
)))))
(
home-page
"https://github.com/corna/me_cleaner"
)
(
synopsis
"Intel ME cleaner"
)
(
description
"This package provides tools for disabling Intel
ME as far as possible (it only edits ME firmware image files)."
)
(
license
license:gpl3+
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment