Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
03d521f9
Commit
03d521f9
authored
9 years ago
by
Taylan Ulrich Bayırlı/Kammer
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add nestopia-ue.
* gnu/packages/games.scm (nestopia-ue): New variable.
parent
ef54b61d
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/games.scm
+60
-0
60 additions, 0 deletions
gnu/packages/games.scm
with
60 additions
and
0 deletions
gnu/packages/games.scm
+
60
−
0
View file @
03d521f9
...
...
@@ -38,6 +38,7 @@ (define-module (gnu packages games)
#
:use-module
(
guix
svn-download
)
#
:use-module
(
gnu
packages
)
#
:use-module
(
gnu
packages
autotools
)
#
:use-module
(
gnu
packages
backup
)
#
:use-module
(
gnu
packages
base
)
#
:use-module
(
gnu
packages
admin
)
#
:use-module
(
gnu
packages
audio
)
...
...
@@ -1212,3 +1213,62 @@ (define-public manaplus
;; "data/themes/{golden-delicious,jewelry}/*" are under CC-BY-SA.
;; The rest is under GPL2+.
(
license
(
list
license:gpl2+
license:zlib
license:cc-by-sa4
.
0
))))
(
define-public
nestopia-ue
(
package
(
name
"nestopia-ue"
)
(
version
"1.46.2"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"https://github.com/rdanbrook/nestopia/archive/"
version
".tar.gz"
))
(
file-name
(
string-append
name
"-"
version
".tar.gz"
))
(
sha256
(
base32
"07h49xwvg61dx20rk5p4r3ax2ar5y0ppvm60cqwqljyi9rdfbh7p"
))
(
modules
'
((
guix
build
utils
)))
;; We don't need libretro for the GNU/Linux build.
(
snippet
'
(
delete-file-recursively
"libretro"
))))
(
build-system
gnu-build-system
)
(
native-inputs
`
((
"pkg-config"
,
pkg-config
)))
(
inputs
`
((
"ao"
,
ao
)
(
"glu"
,
glu
)
(
"gtk+"
,
gtk+
)
(
"libarchive"
,
libarchive
)
(
"mesa"
,
mesa
)
(
"sdl2"
,
sdl2
)))
(
arguments
'
(
#
:phases
(
modify-phases
%standard-phases
;; The Nestopia build system consists solely of a Makefile.
(
delete
'configure
)
;; XXX Should be unnecessary with the next release.
(
add-before
'build
'patch-makefile
(
lambda
_
(
substitute*
"Makefile"
((
"@mkdir \\$@"
)
"@mkdir -p $@"
)
((
"CC ="
)
"CC ?="
)
((
"CXX ="
)
"CXX ?="
)
((
"PREFIX ="
)
"PREFIX ?="
)
((
"^install:\n$"
)
"install:\n\tmkdir -p $(BINDIR)\n"
))))
(
add-before
'build
'remove-xdg-desktop-menu-call
(
lambda
_
(
substitute*
"Makefile"
((
"xdg-desktop-menu install .*"
)
""
)))))
#
:make-flags
(
let
((
out
(
assoc-ref
%outputs
"out"
)))
(
list
"CC=gcc"
"CXX=g++"
(
string-append
"PREFIX="
out
)))
;; There are no tests.
#
:tests?
#f
))
(
home-page
"http://0ldsk00l.ca/nestopia/"
)
(
synopsis
"Nintendo Entertainment System (NES/Famicom) emulator"
)
(
description
"Nestopia UE (Undead Edition) is a fork of the Nintendo Entertainment
System (NES/Famicom) emulator Nestopia, with enhancements from members of the
emulation community. It provides highly accurate emulation."
)
(
license
license:gpl2+
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment