Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
0899144f
Commit
0899144f
authored
9 years ago
by
Andreas Enge
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add xmlsec.
* gnu/packages/xml.scm (xmlsec): New variable.
parent
0c09a306
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/xml.scm
+32
-1
32 additions, 1 deletion
gnu/packages/xml.scm
with
32 additions
and
1 deletion
gnu/packages/xml.scm
+
32
−
1
View file @
0899144f
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2013
, 2015
Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
;;;
;;; This file is part of GNU Guix.
...
...
@@ -20,8 +20,10 @@
(
define-module
(
gnu
packages
xml
)
#
:use-module
(
gnu
packages
)
#
:use-module
(
gnu
packages
autotools
)
#
:use-module
(
gnu
packages
compression
)
#
:use-module
(
gnu
packages
gnupg
)
#
:use-module
(
gnu
packages
gnutls
)
#
:use-module
(
gnu
packages
perl
)
#
:use-module
(
gnu
packages
python
)
#
:use-module
(
gnu
packages
web
)
...
...
@@ -387,3 +389,32 @@ (define-public xmlto
stylesheet for the conversion you want and applies it using an external
XSL-T processor. It also performs any necessary post-processing."
)
(
license
license:gpl2+
)))
(
define-public
xmlsec
(
package
(
name
"xmlsec"
)
(
version
"1.2.20"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"https://www.aleksey.com/xmlsec/download/"
name
"1-"
version
".tar.gz"
))
(
sha256
(
base32
"01bkbv2y3x8d1sf4dcln1x3y2jyj391s3208d9a2ndhglly5j89j"
))))
(
build-system
gnu-build-system
)
(
propagated-inputs
; according to xmlsec1.pc
`
((
"libxml2"
,
libxml2
)
(
"libxslt"
,
libxslt
)))
(
inputs
`
((
"gnutls"
,
gnutls
)
(
"libgcrypt"
,
libgcrypt
)
(
"libltdl"
,
libltdl
)))
(
home-page
"http://www.libexpat.org/"
)
(
synopsis
"XML Security Library"
)
(
description
"The XML Security Library is a C library based on Libxml2. It
supports XML security standards such as XML Signature, XML Encryption,
Canonical XML (part of Libxml2) and Exclusive Canonical XML (part of
Libxml2)."
)
(
license
(
license:x11-style
"file://COPYING"
"See 'COPYING' in the distribution."
))))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment