Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
0931c609
Commit
0931c609
authored
9 years ago
by
Ricardo Wurmus
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add randomjungle.
* gnu/packages/machine-learning.scm (randomjungle): New variable.
parent
71f80f54
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/machine-learning.scm
+49
-1
49 additions, 1 deletion
gnu/packages/machine-learning.scm
with
49 additions
and
1 deletion
gnu/packages/machine-learning.scm
+
49
−
1
View file @
0931c609
...
...
@@ -23,7 +23,12 @@ (define-module (gnu packages machine-learning)
#
:use-module
(
guix
download
)
#
:use-module
(
guix
build-system
gnu
)
#
:use-module
(
gnu
packages
)
#
:use-module
(
gnu
packages
python
))
#
:use-module
(
gnu
packages
boost
)
#
:use-module
(
gnu
packages
compression
)
#
:use-module
(
gnu
packages
gcc
)
#
:use-module
(
gnu
packages
maths
)
#
:use-module
(
gnu
packages
python
)
#
:use-module
(
gnu
packages
xml
))
(
define-public
libsvm
(
package
...
...
@@ -96,3 +101,46 @@ (define-public python-libsvm
(
inputs
`
((
"python"
,
python
)))
(
synopsis
"Python bindings of libSVM"
)))
(
define-public
randomjungle
(
package
(
name
"randomjungle"
)
(
version
"2.1.0"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"http://www.imbs-luebeck.de/imbs/sites/default/files/u59/"
"randomjungle-"
version
".tar_.gz"
))
(
sha256
(
base32
"12c8rf30cla71swx2mf4ww9mfd8jbdw5lnxd7dxhyw1ygrvg6y4w"
))))
(
build-system
gnu-build-system
)
(
arguments
`
(
#
:configure-flags
(
list
(
string-append
"--with-boost="
(
assoc-ref
%build-inputs
"boost"
)))
#
:phases
(
modify-phases
%standard-phases
(
add-before
'configure
'set-CXXFLAGS
(
lambda
_
(
setenv
"CXXFLAGS"
"-fpermissive "
)
#t
)))))
(
inputs
`
((
"boost"
,
boost
)
(
"gsl"
,
gsl
)
(
"libxml2"
,
libxml2
)
(
"zlib"
,
zlib
)))
(
native-inputs
`
((
"gfortran"
,
gfortran-4
.
8
)))
(
home-page
"http://www.imbs-luebeck.de/imbs/de/node/227/"
)
(
synopsis
"Implementation of the Random Forests machine learning method"
)
(
description
"Random Jungle is an implementation of Random Forests. It is supposed to
analyse high dimensional data. In genetics, it can be used for analysing big
Genome Wide Association (GWA) data. Random Forests is a powerful machine
learning method. Most interesting features are variable selection, missing
value imputation, classifier creation, generalization error estimation and
sample proximities between pairs of cases."
)
(
license
license:gpl3+
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment