Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
12edffe4
Commit
12edffe4
authored
9 years ago
by
Ricardo Wurmus
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add libpinyin.
* gnu/packages/ibus.scm (libpinyin): New variable.
parent
5708a92a
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/ibus.scm
+49
-0
49 additions, 0 deletions
gnu/packages/ibus.scm
with
49 additions
and
0 deletions
gnu/packages/ibus.scm
+
49
−
0
View file @
12edffe4
...
...
@@ -24,6 +24,8 @@ (define-module (gnu packages ibus)
#
:use-module
(
guix
build-system
gnu
)
#
:use-module
(
guix
build-system
glib-or-gtk
)
#
:use-module
(
gnu
packages
)
#
:use-module
(
gnu
packages
autotools
)
#
:use-module
(
gnu
packages
base
)
#
:use-module
(
gnu
packages
glib
)
#
:use-module
(
gnu
packages
gnome
)
#
:use-module
(
gnu
packages
gtk
)
...
...
@@ -98,3 +100,50 @@ (define-public ibus
may also simplify input method development."
)
(
home-page
"http://ibus.googlecode.com/"
)
(
license
lgpl2
.
1
+
)))
(
define-public
libpinyin
(
package
(
name
"libpinyin"
)
(
version
"1.2.0"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"https://github.com/libpinyin/libpinyin/archive/"
version
".tar.gz"
))
(
file-name
(
string-append
name
"-"
version
".tar.gz"
))
(
sha256
(
base32
"04didxd39vlry6nqy7xqynwc68ndajnhw334wahfmp7zjbbscs7p"
))))
(
build-system
gnu-build-system
)
(
arguments
`
(
#
:phases
(
modify-phases
%standard-phases
(
add-before
'configure
'autogen
(
lambda
_
(
zero?
(
system*
"autoreconf"
"-vif"
))))
(
add-after
'unpack
'unpack-model
(
lambda*
(
#
:key
inputs
#
:allow-other-keys
)
(
zero?
(
system*
"tar"
"-xvf"
(
assoc-ref
inputs
"model"
)
"-C"
"data"
)))))))
(
inputs
`
((
"glib"
,
glib
)
(
"bdb"
,
bdb
)
(
"model"
,
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"mirror://sourceforge/libpinyin/"
"models/model10.text.tar.gz"
))
(
sha256
(
base32
"0g489wqcfklxphhxpkh8i4qf9y8scmnmdbfrzdbrgf3rignbwyiw"
))))))
(
native-inputs
`
((
"pkg-config"
,
pkg-config
)
(
"autoconf"
,
autoconf
)
(
"automake"
,
automake
)
(
"libtool"
,
libtool
)))
(
synopsis
"Library to handle Chinese Pinyin"
)
(
description
"The libpinyin C++ library provides algorithms needed for sentence-based
Chinese pinyin input methods."
)
(
home-page
"https://github.com/libpinyin/libpinyin"
)
(
license
gpl2+
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment